Commit 2bc90988 authored by Marc Fournier's avatar Marc Fournier

disable smart plugin on non-linux platforms

parent 84b3ba19
collectd (5.5.0-3) UNRELEASED; urgency=medium
* debian/rules:
* debian/rules, debian/control:
- Avoid hiding compiler options, allowing the buildd log scanner to do
it's job.
- Disable smart plugin on non-linux platforms, due to missing
libatasmart-dev build-dependency.
-- Marc Fournier <marc.fournier@camptocamp.com> Tue, 25 Aug 2015 06:55:52 +0200
......
......@@ -8,7 +8,7 @@ Build-Depends: debhelper (>= 7.0.50~), dpkg-dev (>= 1.14.10), po-debconf, dh-sys
iptables-dev (>= 1.4.3.2-2) [linux-any],
javahelper,
kfreebsd-kernel-headers [kfreebsd-any],
libatasmart-dev,
libatasmart-dev [linux-any],
libcap-dev [linux-any],
libcurl4-gnutls-dev (>= 7.18.2-5) | libcurl4-gnutls-dev (<= 7.18.2-1) | libcurl3-gnutls-dev,
libdbi0-dev,
......
......@@ -151,6 +151,11 @@ ifeq (,$(filter amd64 i386, $(DEB_BUILD_ARCH)))
--disable-turbostat
endif
# libatasmart isn't available on these platforms.
ifneq (,$(filter hurd-i386 kfreebsd-i386 kfreebsd-amd64, $(DEB_BUILD_ARCH)))
confflags += --disable-smart
endif
# The hppa buildds currently do not keep up with Java related stuff, thus
# prevending testing transitions. sparc is also having trouble building the
# java plugin.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment